The Story of the Stupid Oven

When we bought the house, we knew everything in it was Old. Old as in orginal to the house that was built in the early 1990's. Because we sold the house for less than we should have (according to Adam) and had expenses from three sold months of eating out (well, what was I going to do?) and the move (not moving ourselves, thanks!) I didn't think a new oven was on the list.

Adam surprised me with a new oven for Mother's Day. (JUST THIS ONCE DOES THIS COUNT.) I was pretty greatful, especially when I got an up close and personal look at the old biege model that was in the kitchen... tipping to one side. I had a super nice oven in the old house and really enjoyed using all the features, like the convection bake to make cookies. (Adam and the kids liked this feature too!)

Our new oven has some features that I like, like the warming drawer, and some things I don't, like the fact that there is no touch pad for the timer and temp control. This means that I turn it on, it goes to 350 and I have to hit the up or down arrow keys to get to any other temp. Um, no.

Then there was the feature that I hated- like the fact that it cooked unevenly! Food towards the back would be done or overdone while food at the front would be underdone or raw. A pan of cookies would be half baked, chicken would be raw and so on. I was informed that this was "my fault" and I would probably have to rotate the cassroles or cookies halfway through.

My response was a crude version of "Who has time for THAT?" and my mother-in-law gave Adam a look that said, "I don't think so." I had picked her brain about this oven and she had given me some tips, so I should have known something was wrong when she did this.

Fastforward to Jan. I went to heat up the oven, using the normal setting and "rapid preheat." (Nice feature, btw.) I went to heat up the oven and the chicken and potatos took way too long to cook. Adam and I stuck our hands in and it was too cool to be 400 degrees, like the panel said. We had leftovers that night and realized that it would cook.... but only with the convection feature. A day or so later, it took over an hour to go from cold to 250... and the end time should have been 350!

The nice repairman came out and said there was a problem with the electrical panel and, when I told him about the uneven cooking and how it took so logn to heat up, said there always had been. After some confusion about when we bought it (in May of 09 not Oct of 08, thanks!) he declared that it was still under warrenty and he would order the part.

Less than a week later, he was back and fixed it.

A few days later, I noticed it was taking a long time ot preheat. MIL came over and said the same thing; that it never preheated when she was trying to make brownies with the kids.

We've called the repairman again. Let's hope the third time is a charm. Honestly, this is stupid. I don't think I'd buy a Whirpool again.